Ant Movie Catalog

Wersja 3.5

Użyj indeksu po lewej do nawigacji po tym pliku pomocy.

Lokalizacja: Bogdan Kwietniak bogdanka@free.pl

Wykorzystano fragmenty lokalizacji wersji 3.4.3 dokonanej przez Adama "Adma's" Malicha admas@interia.pl


Informacje ogólne

Program ten pozwala na katalogowanie posiadanych filmów. Można utworzyć kilka katalogów do szczegółowego podziału filmów. Każdy katalog może zawierać prawie nieskończoną ilość filmów i być przechowywany w formacie własnym programu ".amc" lub uniwersalnym ".xml". Katalogi te są obsługiwane przez ikony [image] "Nowy", [image] "Otwórz", [image] "Zapisz" i [image] "Zapisz jako" w pasku narzędziowym oraz menu Plik.

Kiedy katalog jest otwarty (lub pusty po utworzeniu nowego), możesz dodawać nowe filmy za pomocą ikony [image] "Dodaj", która otworzy okno wyboru numeru filmu (każdy film musi mieć numer, ale program może nadawać je automatycznie, jeśli zaznaczymy "Nie pytaj ponownie; użyj automatycznego numerowania" w tym oknie). Dodając nowe filmy do katalogu nie należy zapominać o okresowym zapisywaniu zmian w katalogu.

Teraz można przystąpić do wypełniania różnych pól. Ikona [image] "Pobierz informacje" wyświetli menu pozwalające importować informacje o filmie z pliku lub skryptu.

  • Importowanie danych z pliku jest użyteczne do zbierania informacji z plików multimedialnych (.avi, .mpeg, itp.). możesz także "przeciągnąć i upuścić" plik z Eksploratora Windows do okna Ant Movie Catalog.
  • Importowanie ze skryptu wyświetla okno Skrypty pozwala pobierać informacje z różnych stron internetowych. Jest to najłatwiejszy sposób na wypełnienie wszystkich pól związanych z filmem, jeśli masz dostęp do Internetu.

Możesz również dołączyć do filmu okładkę w formie obrazka (zapisywany w bazie) bądź linku do pliku graficznego. Niektóre skrypty umożliwiają pobranie okładki podczas importu, ale możesz również dołączyć plik własnoręcznie używając [image] "Wybierz okładkę..." (w lewym dolnym rogu) lub przeciągając obrazek z Eksploratora Windows

Jeśli masz listę filmów w innym formacie (np. Microsoft Excel) możesz użyć okna Importu do przeniesienia danych do bieżącego katalogu.

Nie obawiaj się odkryć pozostałych funkcji dostępnych w menu. Proponuję również poświęcić nieco czasu na zapoznanie się z opcjami dostępnymi w oknie Ustawień dostępnym przez ikonę [image] "Ustawienia".


Informacje o filmie

W głównym oknie programu możesz wprowadzić różne informacje dla każdego filmu :

  • Etykieta filmu: Możesz zapisać tutaj numer dysku, kasety, kod kreskowy, etykietę lub cokolwiek innego
  • Rodzaj nośnika: Typ nośnika, na którym znajduje się film (CD, DVD, VHS, etc...)
  • Źródło: Skąd pochodzi /jak zdobyłeś/ ten film
  • Data dodania: Kiedy film został dodany do listy
  • Pożyczający: Dane znajomego, który pożyczył od ciebie ten film
  • Ocena: Podobał ci się ten film? Możesz to wyrazić tutaj
  • Tytuł oryginalny
  • Tytuł polski
  • Reżyser
  • Producent
  • Kraj
  • Kategoria
  • Rok
  • Czas trwania: Czas trwania filmu w minutach.
  • Obsada
  • URL: Możesz tu wprowadzić adres strony związanej z filmem. Jeśli klikniesz na przycisk z prawej strony pola, program załaduje domyślną przeglądarkę i połączy się z tą stroną.
  • Opis filmu
  • Komentarze
  • Format video: Kodek lub inne oprogramowanie użyte do tego filmu
  • Video bitrate: W kilobitach na sekundę
  • Format audio: Kodek lub inne oprogramowanie użyte do audio
  • Audio bitrate: W kilobitach na sekundę
  • Rozdzielczość: Szerokość i wysokość obrazu (np. 640x480)
  • Framerate: Ilość klatek na sekundę
  • Rozmiar filmu: Rozmiar filmu w megabajtach. Pliki mogą być powiązane lub zsumowane (np. 650+590 lub 1240)
  • Ilość płyt: Ilość dysków lub kaset
  • Język
  • Napisy

Wszystkie nazwy pól są przechowywane w pliku XML, razem z pozostałymi ustawieniami. Możesz je edytować w rozwijanej liście w oknie Ustawień. Jest tam również opcja, aby wykorzystywać ustawienia bieżącego katalogu zamiast predefiniowanych w programie.

Są dwa dodatkowe "pola", które pojawiają się w niektórych oknach:

  • Zaznaczone: Określana stanem znaczników w głównym oknie listy; mogą być one włączone w Ustawieniach, jeśli są niewidoczne.
  • Tytuł sformatowany: Tytuł wyświetlany w głównym oknie listy, składający się np. z tytułu oryginalnego i polskiego; więcej informacji uzyskasz w Ustawieniach


Drukowanie

W tym oknie możesz obejrzeć raporty przed wydrukowaniem.

Wybierz wzór z listy po lewej, aby zobaczyć jak wygląda. Lista ta to właściwie spis odpowiednich plików w podkatalogu "Templates".

Jeśli chcesz załadować wzorzec z innego folderu możesz użyć ikony "Wczytaj".

Tworzone dokumenty są posortowane. Możesz wybrać jedną z podstawowych metod tj. według: numeru, tytułu oryginalnego, polskiego lub sformatowanego, bądź zaawansowaną. Ustawienia dla tej ostatniej są dostępne pod przyciskiem "Zaawansowane". Tam możesz ustalić, które pola i w jakiej kolejności zostaną wykorzystane .

Opcje "Uwzględnij filmy" pozwalają ograniczyć zakres tworzonych dokumentów do wybranych, oznaczonych (patrz opcja "Znaczników") lub widocznych filmów (gdy użyjemy opcji "Pokaż wyniki" w oknie wyszukiwania).

Gdy już zdecydowałeś co wydrukować, po prostu kliknij na przycisk "Drukuj", otworzy się okno wydruku, w którym możesz ustalić drukarkę, zakres wydruku i ilość kopii.

UWAGA: Jeśli chcesz ustalić inny rozmiar papieru, musisz zmodyfikować wzorzec w "Projektancie Raportów" (domyślnie jest ustawiany A4, ale może się to zmieniać, zależnie od autora wzorca).

Jeśli chcesz zmodyfikować lub utworzyć swoje wzorce, kliknij ikonę "Projektanta". Informacje jak go obsługiwać uzyskasz na stronie Tworzenie raportów w części Technicznej niniejszej pomocy.

"Projektant.." jest tylko w wersji angielskiej.


Importowanie

Import z innych formatów

Możesz importować dane do listy filmów z plików innego formatu.

Wybierz jeden z formatów importu z listy, która jest po lewej stronie okna "Import". Następnie wybierz plik źródłowy.

Dostępne formaty plików:

  • CSV (może być użyty do importu z Microsoft Excela i innych programów)
  • AMC (Ant Movie Catalog)
  • BaseDVDivx
  • Divx Manager / eXtreme Movie Manager
  • Origons.com

Opcja "Dopuszczaj duplikaty plików" pozwala ustalić, czy numery filmów mogą się powtarzać. Jeśli podczas importu opcja ta nie jest włączone i trafi się film z numerem już występującym, zostanie mu przydzielony nowy numer.


Import z CSV

CSV jest formatem pliku tekstowego, który jest bardzo użyteczny odkąd wiele programów zezwala na ładowanie i zapisywanie takich plików (np. Microsoft Excel).

W tych plikach wszystkie dane dotyczące filmu są w jednej linii, oddzielone znakiem (zazwyczaj przecinkiem lub średnikiem).

Kiedy importujesz takie pliki, każdy wiersz informacji będzie wzięty pod uwagę jako jeden film na liście. Później ten wiersz jest dzielony na różne pola. Program nie jest w stanie rozróżnić, do których kolumn w zapisie CSV odnoszą się informacje o filmie. Będziesz zatem musiał mu to "wyjaśnić".

Żeby to zrobić będziesz musiał wybrać nazwę pola z rozwijanej listy "Dostępnych nazw pól" i później kliknąć na tytule kolumny (nagłówek) zgodnie z wybraną wartością, jak na obrazku poniżej

Powtórz ten krok dla każdej kolumny, którą chcesz zachować.

Jeśli nie skojarzysz nazwy pola z nagłówkiem kolumny, dane dla tej kolumny nie zostaną importowane.

Jeśli kolumna "Numer" nie zostanie przydzielona, numery zostaną stworzone poczynając od najwyższego numeru filmu +1.


Import z AMC

Import z Ant Movie Catalog

Ta opcja pozwala na import filmów z innego katalogu. Możesz importować pliki z jakiejkolwiek wersji Ant Movie Catalog, oczywiście oprócz wersji nowszych, niż bieżąca.

PS: Kiedy uaktualniasz wersję Ant Movie Catalog, nie musisz importować swojego katalogu do nowej wersji. Możesz bezpośrednio otworzyć ten katalog, a program przekonwertuje go i zapisze.


Import z BaseDVDivX

BasDVDivx jest francuskim managerem filmów, który używa plików z rozszerzeniem ".bdv" z bazy danych MyLittleBase.

Do tej pory został pomyślnie przetestowany import plików zrobionych w wersji BaseDVDivx 2.5.

Jeśli w katalogu są obrazki, program zapyta cię co chcesz z nimi zrobić. Masz do wyboru 4 opcje :

  • Schowek: Zachowuje okładki w katalogu. Jeśli okładki są duże, rośnie też plik. Jeśli zapiszesz okładki do XML, będą one reeksportowane podczas zapisywania, ponieważ nie mogą być one przechowywane w pliku XML.
  • Kopia + Link: Kopiuje okładki do folderu bieżącego katalogu, a następnie linki do niego. Zatem, oryginalne okładki nie są więcej potrzebne. Ta opcja nie jest dostępna jeśli bieżący plik nie został jeszcze nigdzie zapisany.
  • Link: Tworzy link do okładek, do ich oryginalnej lokalizacji. Musisz więc trzymać okładki w jednym miejscu.
  • Bez okładek: Puste pole okładek.

Jest także ukryty, piąty wybór: jeśli kasujesz to okno (z przyciskiem X w rogu lub przez naciśnięcie Esc) pole okładek nie będzie zmodyfikowane i będzie zawierało nazwę pliku, tak jak w importowanej bazie danych. Możesz kopiować okładki manualnie do folderu tego katalogu.


Import z Divx Managera

Divx Manager jest managerem filmowym, który używa bazy danych Microsoft Access z rozszerzeniem ".mbd".

Strona programu: www.binaryworks.it/extrememoviemanager

Do tej pory zostało pomyślnie przetestowane importowanie próbek plików, które towarzyszą wersjom 0.5, 0.6, 0.8, 0.9 i 1.0 Divx Managera.

Jeśli w katalogu są okładki, to program zapyta cię co z nimi zrobić. Masz pięć opcji do wyboru :

  • Schowek: Zachowuje okładki w katalogu. Jeśli okładki są duże, rośnie też plik. Jeśli zapiszesz okładki do XML, będą one reeksportowane podczas zapisywania, ponieważ nie mogą być one przechowywane w pliku XML.
  • Kopia + Link: Kopiuje okładki do folderu bieżącego katalogu, a następnie linki do niego. Zatem, oryginalne okładki nie są więcej potrzebne. Ta opcja nie jest dostępna jeśli bieżący plik nie został jeszcze nigdzie zapisany.
  • Link: Tworzy link do okładek, do ich oryginalnej lokalizacji. Musisz więc trzymać okładki w jednym miejscu.
  • Bez okładek: Czyste pole okładek.

Jest także ukryty, piąty wybór: jeśli kasujesz to okno (z przyciskiem X w rogu lub przez naciśnięcie Esc) pole okładek nie będzie zmodyfikowane i będzie zawierało nazwę pliku, tak jak w importowanej bazie danych. Możesz kopiować okładki manualnie do folderu tego katalogu.


Import z Origons.com

Opcja ta pozwoli ci importować plik zawierający twoją listę filmów w znormalizowanym formacie, który został wygenerowany na stronie internetowej Origons. Strona ta umożliwia zarządzanie twoją listą filmów online: www.origons.com.


Eksportowanie

Eksport do innych formatów

Możesz w prosty sposób eksportować listę filmów do poniższych formatów w celu opublikowania, wymiany albo wydruku.

Dostępne formaty:

  • HTML
  • CSV (może zostać wczytany do Microsoft Excella i innych programów)
  • SQL
  • Tylko okładki
  • Origons.com

Możesz określić metodę sortowania według: numeracji, tytułu oryginalnego, tytułu polskiego lub skorzystać z zaawansowanych metod sortowania. Kiedy wybierzesz ostatnią opcję otworzy się okno i będziesz mógł wybrać, które pola zostaną wykorzystane przy sortowaniu, i w jakiej kolejności.

Opcja "Uwzględnij filmy" pozwala ograniczyć eksport plików jedynie do wybranych, zaznaczonych (jest to powiązane z opcją ("Znaczników" ) oraz widocznych (jeśli zaznaczono opcję "Pokaż wyniki" w oknie wyszukiwania filmów).

Opcja "Kopiuj okładki do tego samego folderu, co eksportowane pliki" pozwala wyeksportować również okładki do tego samego folderu co filmy.


Eksport do HTML

Opcja "Eksport do HTML" pozwala na stworzenie pliku HTML, który będzie zawierał pełny katalog w przenośnym formacie. Możesz umieścić listę na stronę WWW lub dać ją komukolwiek, kto ma przeglądarkę internetową.

Wygenerowany plik HTML jest oparty na rzeczywistym pliku HTML. Program wymienia specjalne identyfikatory z filmem i informacją w katalogu.

Są dwa szablony: "Ogólny" i "Indywidualny". Stare wersje mają tylko szablon "Ogólny". Szablon "Ogólny" jest tylko jednym plikiem z listą filmów (wykorzystywanym np. jako spis dla indywidualnego). Jego nazwa jest nazwą, którą wybierasz kiedy klikasz na "Eksport". Szablon indywidualny jest plikiem dotyczącym jednego filmu. Domyślnie jego nazwa ustalana jest na podstawie podanej po kliknięciu "Eksport", z numerem filmu dołączonym na końcu (możesz to zmienić w oknie Ustawień).

Zatem, jeśli eksportujesz filmy do pliku "Moje filmy.html" otrzymasz:

  • Moje filmy.html -> Lista filmów, oparta na załadowanym pełnym szablonie
  • Moje filmy_1.html -> Pierwszy film, oparty na szablonie załadowanym w oknie "Indywidualny"
  • Moje filmy_2.html -> Drugi film, oparty na szablonie załadowanym w oknie "Indywidualny"
  • itd...

Po prawej stronie przycisków wyboru szablonów (przyciski "Ogólny" / "Indywidualny") możesz wybrać czy chcesz eksportować oba szablony, czy tylko wybrany w tej chwili

Wszystkie tagi zaczynają się od "$$". Nie musisz ich znać ponieważ możesz je dodać w menu "Wstaw dodatkowy tag". Zawierają one wszystkie te informacje, które możesz wprowadzić dla filmu w głównym oknie, a także całkowitą ilość filmów, nazwę katalogu, bieżącą datę i czas.

Są dwa bardzo ważne tagi dla szablonu "ogólnego": $$ITEM_BEGIN i $$ITEM_END. Kiedy tworzysz plik HTML, program powtórzy kod HTML, który jest pomiędzy tymi dwoma tagami dla każdego filmu. Zatem wszystkie tagi zaczynające się $$ITEM_ muszą zostać umiejscowione pomiędzy tymi dwoma tagami. Z drugiej strony, te tagi są bezużyteczne dla szablonu "indywidualnego".

Aplikacja zawiera przykładowe szablony, które możesz użyć lub przerobić. Oczywiście, możesz stworzyć nowy szablon jeśli wolisz, ale zalecałbym przyjrzeć się najpierw temu podstawowemu szablonowi :

<html>
  <head><title>$$FILENAME</title></head>
  <body><table>
    $$ITEM_BEGIN
      <tr>
        <td>$$ITEM_NUMBER</td>
        <td>$$ITEM_ORIGINALTITLE</td>
        <td>$$ITEM_TRANSLATEDTITLE</td>
        <td>$$ITEM_DESCRIPTION</td>
      </tr>
    $$ITEM_END
  </table></body>
</html>

Możemy tutaj zauważyć, że strona będzie nazwą pliku jak w tytule, z tabelą zawierającą wszystkie filmy. Program po tagu <table> powtórzy sekwencję <tr>...</tr> dla każdego filmu, ponieważ jest pomiędzy $$ITEM_BEGIN i $$ITEM_END.

Oto lista dostępnych tagów:

  • $$DATE = Bieżąca data
  • $$TIME = Bieżący czas

Dane związane z katalogiem:

  • $$FILENAME = Nazwa katalogu
  • $$FILEPATH = Nazwa katalogu z pełną ścieżką
  • $$TOTALMOVIES = Ilość filmów w katalogu
  • $$OWNER_NAME = Nazwa podana we właściwościach katalogu
  • $$OWNER_MAIL = E-mail
  • $$OWNER_SITE = Strona WWW
  • $$DESCRIPTION = Opis
  • $$ITEM_FILEINDIV = Nazwa indywidualnej strony dla bieżącego filmu
  • $$ITEM_BEGIN = Początek listy filmów
  • $$ITEM_END = Koniec listy filmów

    Pola filmu:

  • $$ITEM_NUMBER = Numer
  • $$ITEM_CHECKED = Zaznaczony/niezaznaczony
  • $$ITEM_MEDIA = Etykieta filmu
  • $$ITEM_TYPE = Rodzaj nośnika
  • $$ITEM_SOURCE = Źródło
  • $$ITEM_DATEADD = Data dodania
  • $$ITEM_BORROWER = Komu wypożyczony
  • $$ITEM_RATING = Ocena (0 do 10)
  • $$ITEM_APPRECIATION = Uznanie, od 0 do 4 gwiazdek, używając plików appr*.gif
  • $$ITEM_ORIGINALTITLE = Tytuł oryginalny
  • $$ITEM_TRANSLATEDTITLE = Tytuł polski
  • $$ITEM_FORMATTEDTITLE = Tytuł sformatowany zgodnie z definicją w Ustawieniach
  • $$ITEM_DIRECTOR = Reżyser
  • $$ITEM_PRODUCER = Producent
  • $$ITEM_COUNTRY = Kraj
  • $$ITEM_CATEGORY = Kategoria
  • $$ITEM_YEAR = Rok
  • $$ITEM_LENGTH = Czas trwania w minutach
  • $$ITEM_ACTORS = Obsada
  • $$ITEM_URL = Adres strony www (bez linka)
  • $$ITEM_DESCRIPTION = Opis
  • $$ITEM_COMMENTS = Komentarze
  • $$ITEM_VIDEOFORMAT = Format video/kodek
  • $$ITEM_VIDEOBITRATE = Video bitrate
  • $$ITEM_AUDIOFORMAT = Format audio/kodek
  • $$ITEM_AUDIOBITRATE = Audio bitrate
  • $$ITEM_RESOLUTION = Rozdzielczość obrazu
  • $$ITEM_FRAMERATE = Ilość klatek
  • $$ITEM_LANGUAGES = Język
  • $$ITEM_SUBTITLES = Napisy
  • $$ITEM_SIZE = Rozmiary plików
  • $$ITEM_DISKS = Ilość dysków lub kaset
  • $$ITEM_PICTURE = Okładka, osadzona w tagu <img>
  • $$ITEM_PICTUREFILENAME = Nazwa pliku z okładką


Eksport do CSV

Export to CSV

CSV jest formatem pliku tekstowego, który jest naprawdę użyteczny odkąd wiele programów zezwala na ładowanie i zapisywanie takich plików (np. Microsoft Excel).

W plikach tego typu każda informacja znajduje się w osobnej linii i wszystkie pola tej informacji są oddzielone znakiem (zazwyczaj przecinkiem lub średnikiem).

Jeśli włączysz eksport okładki, zostanie dodana kolumna "Okładka" zawierająca nazwę pliku okładki.


Eksport do SQL

To nie jest prawdziwy format pliku, ale ta opcja eksportu pozwoli ci wygenerować wszystkie komendy SQL , które są użyteczne do łatwego importu listy filmów z bazy danych.

Zamysłem było stworzenie bazy danych SQL widzianej na stronie generowanej za pomocą PHP. Jest to bardziej wygodne dla ludzi, którzy chcą obejrzeć twoją listę filmów w sieci.

Jeśli włączysz eksport okładki (opcje na dole okna), zostanie dodane pole "PICTURENAME", zawierające nazwę pliku okładki.

Jest opcja generowania zapytań UPDATE zamiast zapytań INSERT, jeśli chcesz uaktualnić informacje bez uprzedniego kasowania już istniejących danych. Opcja ta aktualizuje dane na podstawie numerów filmów, więc może to powodować problemy jeśli zmieniłeś numery niektórych filmów. Z tego samego powodu, pole "NUMBER" będzie usunięte z wybranych pól, kiedy będziesz eksportował tym sposobem.


Eksport tylko okładek

Funkcja ta pozwala na eksport wszystkich okładek z katalogu.

Nazwy tworzonych obrazków ustala jedna z opcji:

  • Dodaj numer filmu do wybranej nazwy pliku: Kiedy klikniesz "Eksport" musisz podać nazwę pliku. Ta nazwa pliku będzie użyta jako podstawa dla nazw obrazków; program automatycznie dołączy numer filmu do nazwy pliku.
  • Użyj numeru filmu: okładki będą tylko ponumerowane zgodnie z filmem do którego są przypisane
  • Użyj tytułu sformatowanego (jaki został zdefiniowany w opcjach dla listy filmów): używa tego samego formatowania jak lista filmów w głównym oknie.


Eksport do Origons.com

Możesz wygenerować plik w standaryzowanym formacie, za pomocą którego będziesz mógł eksportować listę swoich filmów na stronę internetową Origons. Ta strona umożliwi ci na zarządzanie twoją listą filmów online: www.origons.com.


Wypożyczanie filmów

Ta funkcja pozwoli ci zarządzać filmami, które pożyczyli od ciebie twoi znajomi.

Lista na górze zawiera wszystkie filmy bieżącego katalogu. Na dole po lewej znajduje się lista pożyczających. Na dole po prawej są filmy pożyczone przez wybraną osobę (na liście po lewej).

Żeby zaznaczyć film jako "WYPOŻYCZONY" musisz wybrać zarówno film jak i pożyczającego. Następnie możesz użyć przycisku "WYPOŻYCZENIA" lub kliknąć dwukrotnie na filmie.

Żeby usunąć status filmu "WYPOŻYCZONY", wybierz go na liście pożyczającego i użyj przycisku "ZWROTY" lub kliknij podwójnie na filmie.

Możesz wybrać na raz kilka filmów korzystając z klawiszy CTRL lub SHIFT.

Jeśli użyłeś unikalnego numeru lub pola "Etykieta" do oznaczenia kilku filmów na tym samym nośniku, możesz użyć "Dołącz filmy z tym samym numerem" i/lub "Dołącz filmy z tą samą etykietą" dostępnych z mini-menu Opcje.
Jeśli zostaną one wybrane, filmy z tym samym numerem lub etykietą zostaną automatycznie dołączone do wypożyczonych danej osobie (chyba, że zostały wcześniej przydzielone komuś innemu).

Wszystkie operacje (Wypożyczone/Zwrócone) są zapamiętywane w pliku tekstowym.

Więcej informacji uzyskasz na stronie Ustawień


Skrypty

Ten moduł umożliwia uzyskanie informacji o filmie z internetu i importowanie ich do swojego katalogu oraz przetwarzanie listy filmów

Kiedy okno jest wywołane przez "Pobierz informacje" -> "z Internetu używając skryptu", widoczne są jedynie skrypty dla wersji 3.5 (lub wyższej) i te przeznaczone dla pobierania informacji z Internetu. Domyślnie skrypt jest uruchamiany dla zaznaczonych filmów.
Jeśli okno wywoływane jest przez menu "Skrypty" widoczne są wszystkie skrypty.

Możesz zawęzić ilość wyświetlanych skryptów. Wybór taki oparty jest o odpowiednie definicje językowe we właściwościach skryptu (język pobieranych przez skrypt informacji). Jest to użyteczne przy zbieraniu informacji ze stron np. tylko w danym języku. Opcję tą obsługuje "Filtr językowy".

Uruchomić skrypt można: klikając na "Uruchom", robiąc dwuklik na nazwie skryptu albo naciskając klawisz Enter lub F9.

Opcje "Uwzględnij filmy" pozwalają ograniczyć zakres tworzonych dokumentów do wybranych, oznaczonych (patrz opcja "Znaczników") lub widocznych filmów (gdy użyjemy opcji "Pokaż wyniki" w oknie wyszukiwania). Domyślnie skrypt jest uruchamiany dla wybranych filmów.

Skrypt jest uruchamiany dla każdego filmu odpowiadającego wybranym kryteriom. Po każdym uruchomieniu okno podsumowania pokazuje poprzednie i obecne wartości (jeśli "Pokaż okno rezultatów" jest zaznaczone).

W oknie "Pola do modyfikacji" możesz określić, które pola mogą zostać zmodyfikowane przez skrypt.

Jeśli skrypt na to pozwala, to w oknie "Opcje skryptu" zostanie wyświetlona ich lista. Dwuklik na opcji pozwala na jej zmianę.

Włączenie "Zamknij po zakończeniu", samoczynnie zamknie okno po wykonaniu skryptu, chyba że klikniesz "Przerwij" lub wystąpi błąd w skrypcie.

Okno rezultatów

Jeśli klikniesz "Zapisz" w oknie rezultatów, zostaną zapisane nowe wartości dla zaznaczonych pól. Gdy klikniesz "Zapisz wzór", okno rezultatów nie będzie pokazywane dla następnych filmów. Program zapyta się czy modyfikowane mają być pola zaznaczone w oknie rezultatów czy zdefiniowane wcześniej (Pola do modyfikacji).

UWAGA: Jeśli zaznaczone zostanie wcześniej "Uwzględnij puste pola", to gdy nowa wartość będzie pusta - skasuje poprzednią. Normalnie puste pola są pomijane przy modyfikacji.

Przycisk "Pomiń" pozwala przejść do następnego filmu bez modyfikacji bieżącego.
Przycisk "Przerwij" zatrzymuje wykonywanie skryptu na bieżącym filmie bez jego modyfikacji (zmiany w już opracowanych filmach pozostaną zapisane).

Podczas importu danych z Internetu, jeśli znaleziono więcej niż jeden film (częste na niektórych stronach), pojawi się lista wyboru właściwego filmu. Niektóre skrypty pozwalają na wybór z listy znalezionych danych (np. wśród kilku dostępnych komentarzy).

Jeśli chcesz uzyskać więcej informacji o pisaniu skryptów, zobacz do Tworzenia skryptów w części Technicznej.


Ustawienia

  • Opcje ogólne
    • Ikony Paska narzędzi
  • Pliki
  • Lista filmów
    • Formatowanie tytułu
  • Informacje o filmie
    • Listy rozwijane
    • Import plików medialnych
    • Import okładek
    • Szukaj w Internecie
  • Skrypty
  • Eksport
  • Foldery

Opcje ogólne

Zestaw ikon : Pozwala ustalić "temat" ikon, które pojawiają się w pasku narzędziowym. Są to proste bitmapy (".bmp") przechowywane w podkatalogu "Toolbars". Do programu dołączonych jest kilka zestawów ikon.

Schemat kolorowania : Określa jak zachowują się ikony, jeśli nie są wskazane myszką. Dostępne są tryby : "Automatyczny", "Szare, gdy nieaktywne" (styl Windows 98/2000), "Jasne, gdy nieaktywne" (styl Office/Windows XP), "Ciemne, gdy nieaktywne" lub "Zawsze widoczne".

Styl Office XP : Menu i pasek zachowują się jak w Microsoft Office XP.

Ikony w menu : Wyświetla ikony przy nazwach w menu. Są one identyczne z tymi w pasku.

Brak cieniowania dla listy filmów, panelu informacji o filmie i okna okładek : Jeśli zostanie zaznaczone, obramowania wymienionych okien staną się bardziej "miękkie". Może to wyglądać lepiej, jeśli używasz Windows XP z inną skórką, niż Windows Classic.

Pokazuj logo powitalne : przy starcie programu wyświetlane jest logo.

Ikony Paska narzędzi

Możesz wybrać, które ikony powinny być wyświetlane na głównym pasku narzędzi. Zajrzyj na tą stronę w celu uzyskania więcej informacji.

Pliki

Zawsze twórz kopię bezpieczeństwa : Za każdym razem podczas zapisywania katalogu, rozszerzenie poprzedniego pliku zostanie zmienione na ".bak".

Podczas startu automatycznie otwieraj... : Pozwala sprecyzować, który plik ma się otworzyć zamiast tworzenia nowego pliku przy starcie. Opcja "Ponowne uruchomienie - otwieraj ostatnio użyty plik" otwiera ten plik, zamiast pliku wyszczególnionego.

Pokaż w menu liczbę ostatnio otwieranych plików : Ostatnio używane pliki są wyświetlane w menu "Plik", powyżej "Wyjścia", żeby pozwolić ci szybko ponownie otworzyć te pliki. Możesz tutaj wybrać liczbę plików, które mają być przechowywane w historii.

Skojarz rozszerzenie z AMC : Przepisuje do rejestru Windows wartości, które pozwolą otworzyć pliki .amc przez Ant Movie Catalog klikając na nich podwójnie.

Historia wypożyczeń : Zapisuje wszystkie zmiany w wypożyczeniach (wypożyczenia/zwroty) w pliku tekstowym, używając formatu CSV (więc możesz otworzyć go takimi programami jak Excel). Domyślnie plik jest przechowywany w folderze aplikacji i nazywa się "Loans history.csv". Ten sam plik jest współdzielony przy każdym uruchomieniu Ant Movie Catalog, więc możesz mieć problemy jeśli będziesz chciał wykorzystać to okno w kilku programach na raz (w późniejszym terminie zostanie to usprawnione).

Lista filmów

Znaczniki : Jeśli ta opcja jest włączona, to na liście filmów pojawią się znaczniki w głównym oknie. Znaczniki pozwalają sprecyzować, czy dany film jest już dostępny w twojej kolekcji czy nie lub, czy go już oglądałeś, czy też cokolwiek innego. Kiedy eksportujesz katalog możesz wybrać do eksportu tylko zaznaczone filmy. Domyślnie wszystkie filmy są zaznaczone więc jeśli nie używasz tego ustawienia nie będzie to dla ciebie problem.

Gorąca ścieżka : Podkreśla pozycje na liście, kiedy przesuwasz po nich myszką.

Wzbogacony pasek przewijania : Używa poprawionego paska przewijania w okna głównym i oknie pożyczających.

Kolumna "Numer filmu" : Pokazuje lub ukrywa kolumnę zawierającą numery filmów po lewej stronie listy filmów. Jeśli nie używasz numerów, ukrycie tej kolumny pozostawia więcej miejsca dla innych informacji.

Nie twórz grupy dla wartości, które byłyby same w tej grupie : Kiedy używane jest funkcja "Grupuj...", jeśli zaznaczona jest ta opcja grupa zostanie utworzona tylko, gdy są dwa lub więcej filmów w danej kategorii. Wszystkie pozostałe (pojedyncze) filmy zostaną wyświetlone razem. Może to być użyteczne podczas grupowania według numerów lub etykiet.

Umieść filmy z pustymi wartościami w specjalnej grupie : Dla takich filmów zostanie utworzona specjalna grupa "pozostałe", zamiast umieszczania ich bezpośrednio na liście.

Umieść te filmy w specjalnej grupie : Umieści filmy w grupie "inne" zamiast bezpośredniego umieszczania na liście.

Umieść filmy z pustymi wartościami w specjalnej grupie : Podczas grupowania, przy włączonej tej opcji utworzona zostanie grupa "brak określenia" dla filmów, które nie mają określenia w danej kategorii.

Pokaż ilość w grupie : W trybie "Grupuj" przy każdej grupie jest wyświetlana ilość filmów w danej kategorii.

Rozwiń listy w każdej grupie : W trybie "Grupuj" i włączonej tej opcji, wszystkie grupy będą automatycznie rozwijane.

Potwierdzaj usuwanie : Program poprosi o potwierdzenie usunięcia filmu z listy

Potwierdzaj zmiany : Program poprosi o potwierdzenie przed cofnięciem wprowadzonych zmian do danego filmu.

Skróty klawiszowe, Poprzedni/Następny film : pozwala zdefiniować skrót do poprzedniego lub następnego filmu bez utraty z pola widzenia bieżącego pola. Jest to użyteczne przy modyfikowaniu jednego pola w wielu filmach bez potrzeby użycia myszki w celu wybrania kolejnego filmu. Klawiszem domyślnym jest Ctrl + Page Up/Down, który spełnia tą samą funkcję co Ctrl + Num 9/3.

Formatowanie tytułu

Pokaż tytuł :

  • Tytuł oryginalny : Wyświetla tylko oryginalny tytuł.
  • Tytuł polski : Wyświetla polski tytuł jeśli jest dostępny, w przeciwnym wypadku wyświetla tytuł oryginalny.
  • Tytuł oryginalny (Tytuł polski) : Wyświetla jako pierwszy tytuł oryginalny, a następnie polski jeśli jest dostępny.
  • Tytuł polski (Tytuł oryginalny) : Wyświetla jako pierwszy tytuł polski, a następnie tytuł oryginalny. Jeśli polski tytuł nie jest dostępny, wyświetlany jest tylko tytuł oryginalny.
  • Etykieta filmu : pokazuje zamiast tytułów etykiety filmów.

Autoodświeżanie listy filmów podczas wpisywania tytułu : Jeśli ta opcja jest uaktywniona, tytuł filmu na liście będzie odświeżony w każdej chwili, gdy naciśniesz przycisk myszy trzymając kursor w polu. Jeśli nie jest uaktywniona ta opcja, lista filmów będzie odświeżana tylko wtedy, gdy wybierzesz inny film.

Następujące prefiksy na końcu tytułu : Możesz sprecyzować tutaj listę prefiksów, które będą się znajdowały na końcu tytułu filmu (np. "The Matrix" zmieni się na "Matrix, The"). Domyślnie lista ta posiada angielskie i francuskie prefiksy.
Wprowadzając prefiksy wpisz każdy w oddzielnej linii, bez spacji i cudzysłowa (prefiks będzie rozpoznany jeśli w tytule filmu znajduje się za nim spacja lub cudzysłów).
W tej chwili nie są dostępne inne języki, ponieważ mogłoby to powodować problemy, np. niemieckie "Die" po angielsku ("The") wyświetli film "Die Hard" jako "Hard, Die" co nie jest poprawne. Ale możesz zmienić te prefiksy sam dopasowując je do własnego języka.

Informacje o filmie

Pytaj o numer : Podczas dodawania filmu pojawi się okienko, które umożliwi ci wybór numeru nowego filmu. Jeśli ta opcja jest wyłączona numer filmu będzie nadany domyślnie jako numer najwyższy + 1, chyba że wybierzesz kolejną opcję :

Użyj pierwszego dostępnego ... : Użyje domyślnie pierwszego dostępnego numeru zamiast najwyższego + 1.

Otwórz okno "Pobierz informacji..." : Kiedy dodasz film otworzy się okno importu z pliku lub skryptu.

Edycja domyślnych wartości filmu : Wyświetla okno pozwalające na modyfikowanie wartości, które zostaną automatycznie wprowadzone w momencie dodawania nowego filmu do listy.

Ocena - Nie pokazuj ułamków ... : Jeśli opcja ta jest włączona, ocena może być wyłącznie liczbą całkowitą, jak w poprzednich wersjach.

Kolor tła : Pozwala wybrać kolor, jaki będzie użyty jako tło w Oknie Okładki np. jeśli na twojej stronie tło jest białe, to możesz i tu oglądać okładki na takim tle. Domyślnym ustawieniem jest ButtonFace, który jest zgodny z kolorem okien dialogowych i przycisków w Windows.

Dopasuj okładkę do okna : Powiększa/zmniejsza okładkę, aby do oglądania nie był potrzebny pasek przewijania.

Listy rozwijane

Listy te zawierają domyślne ustawienia dla niektórych pól opisu filmu. Aby je uzupełnić lub zmienić należy u góry okna wybrać o które pole chodzi, natomiast w dolnej części wprowadzić żądane zmiany.

Te same opcje dla wszystkich list : Zachowuje te same opcje dla wszystkich list.

Autosortowanie pozycji : Sortuje zawartość list alfabetycznie.

Autouzupełnianie w czasie wpisywania : Jeśli ta opcja jest włączona, to podczas wpisywania tekstu, w głównym oknie pojawi się "sugestia" pasującej wartości - tak jak podczas wpisywania adresu w przeglądarce internetowej. Mogą przy tym powstać problemy związane z posiadaniem kilku podobnych wpisów.

Użyj wartości aktualnego katalogu, zamiast pierwotnie zdefiniowanej listy : Nie używa wartości wprowadzonych dla list, ale przeszukuje bieżący katalog w celu znalezienia wartości do wyświetlenia w tych listach.

Automatycznie dodawaj wartości, których nie ma listach : Jeśli wprowadzona wartość nie figuruje na danej liście, wartość ta zostanie automatycznie dodana (np. jeśli wprowadzisz kraj, którego nie ma jeszcze na liście, program dołączy go do listy).

Import plików medialnych

Pobierz informacje z pliku :Pozwala sprecyzować sposób działania, kiedy plik video jest wprowadzony do głównego okna (np. z Windows Explorera) lub kiedy użytkownik chce uzyskać informację z plików (z menu).

  • Importuj etykietę płyty : Pobiera nazwę z nośnika na którym znajduje się plik w umieszcza w polu "Etykieta".
  • Importuj nazwę pliku jako tytuł : Umieszcza nazwę pliku w polu "Tytuł oryginalny".
  • Importuj ścieżkę pliku do pola URL : Umieszcza pełną ścieżkę pliku w polu URL.
  • Importuj wielkość : Odczytuje rozmiar wybranych plików. Mogą one zostać zsumowane lub tylko zapisane ze znakiem "+" pomiędzy każdą wartością, zależnie od wybranego trybu.
  • Importuj czas trwania : Odczytuje długość pliku (w minutach) i umieszcza w polu "Czas trwania".
  • Użyj wewnętrznych procedur ... : Domyślnie MediaInfo.dll jest używany dla wszystkich rodzajów plików multimedialnych za wyjątkiem AVI, ponieważ Ant Movie Catalog ma własny silnik dla tego formatu, który jest znacznie szybszy, choć mniej dokładny.

Pobierz dane z pliku audio/video : Umieszcza odczytane dane w odpowiednich polach. Dla plików AVI, jeśli używasz wbudowanych procedur, nazwy kodeków są zdefiniowane z pliku "Codecs.ini".

Import okładek

Importowanie okładek z zewnętrznych źródeł : Podczas importu obrazków możliwe jest kilka sposobów powiązania ich z filmem :

  • Przechowuj okładkę w katalogu : Okładka zostanie zapisana w pliku katalogu; ta opcja działa wyłącznie, jeśli katalog zostanie zapisany w formacie ".amc", a nie ".xml". Zależnie od wielkości obrazków, może to prowadzić do powstawania bardzo dużych plików, co z kolei prowadzi do większego wykorzystania pamięci i dłuższego ładowania. Dla dużych plików stanowczo doradza się nie używanie tej opcji.
  • Kopiuj okładkę do folderu katalogu i połącz z katalogiem : Kopiuje obrazek do folderu, w którym zapisany jest katalog i tworzy odnośnik do obrazka (w katalogu przechowywana jest tylko nazwa pliku).
  • Tylko łącze do okładki : Zapisuje tylko ścieżkę do pliku w katalogu. "Twórz względną ścieżkę może być wykorzystane, jeśli folder katalogu i okładek są podobne np. katalog jest w folderze "moje dokumenty\katalogi\filmy.amc", zaś okładki w "moje dokumenty\moje obrazy\okładki". To pozwala nie troszczyć się o dokładne położenie obu folderów.
    Z drugiej strony, jeśli przeniesiemy plik katalogu do innego folderu bez przeniesienia okładek - nie będą one wyświetlane.

Te same opcje są dostępne w oknie "Wybór okładki".

Trzecia opcja jest niedostępna przy skryptach internetowych w bieżącej wersji, gdyż tylko "lokalne" odnośniki są dopuszczalne.

Obrazki przechowywane w tym samym folderze co katalog są z nim trwale związane, więc zostaną skasowane podczas aktualizacji okładek (np. jeśli zmienimy okładkę danego filmu na inną stary obrazek zostanie usunięty).
Aby tego uniknąć należy przechowywać obrazki np. w podfolderze "obrazki" i dodawać je do bazy z wykorzystaniem odnośników. Pozwoli to również na łatwiejsze przenoszenie danych (wystarczy skopiować folder katalogu wraz z podfolderem).

Szukaj w Internecie

Tu można dopasować menu "Szukaj w Internecie" do swoich potrzeb. Menu to zawiera adresy stron internetowych. Po wybraniu jednego z nich uruchomiona zostanie domyślna przeglądarka i nawiązane połączenie z wybraną stroną zaś do adresu, w miejsce "%s", wstawiony zostanie tytuł filmu. Pozwala to na wyszukiwanie danych o filmie w Internecie, bez aktualizacji danych w katalogu.

Nazwy stron muszą być niepowtarzalne. Jeśli chcesz oddzielić jakąś grupę adresów, wystarczy jako nazwę wstawić "-" z liczbą lub literą; pole adresu w tym wypadku jest ignorowane.

Skrypty

Automatycznie uruchom skrypt przy starcie : Uruchamia ostatnio wybrany skrypt przy otwieraniu się okna "Pobierz informacje ze skryptu", bez konieczności wybierania.

Użyj proxy podczas połączenia z Internetem : Pozwala sprecyzować dane na temat serwera proxy.

Utrzymuj połączenie : Domyślnie połączenie z internetem jest zamykane po każdym zapytaniu (o stronę czy okładkę). Jeśli ta opcja jest zaznaczona, połączenie nie zostanie zamknięte automatycznie. Może to trochę podnieść prędkość, ale pozostawiłem to jako opcję ponieważ wielu ludzi miało problemy, kiedy połączenie było cały czas otwarte. Jeśli otrzymujesz informacje o błędzie jak np. "Connection closed gracefully" po aktywowaniu tej opcji, to nie włączaj jej.
Oczywiście opcja ta dotyczy połączeń modemowych.

Eksport

Automatycznie wczytuj ostatnio używany szablon : Zapamiętuje nazwę otwartego szablonu, więc będzie on samoczynnie otwierany przy każdym pojawieniu się tego okna.

Koniec linii będzie zastąpiony... : Pozwala na modyfikację taga użytego do stawiania przerw w liniach. Ponieważ to jest jedyny tag, którego ten program nie pobiera z szablonu, możesz go tutaj zdefiniować. Jeśli chcesz użyć HTML, prawdopodobnie użyjesz domyślnego taga <br>, ale możesz też użyć <br /> dla XHTML lub XML. Możesz także po prostu zostawić to pole puste, jeśli nie chcesz wymieniać końca linii na coś innego.

Wymuś rozmiar obrazka przez dodanie wartości : Pozwala wyszczególnić wartości cech HTML takich jak : wysokość & szerokość. Jeśli zostawisz jedno z tych pól (albo oba) puste, to wartość ta nie będzie dodana.

Format daty SQL : Pozwala zdefiniować, który format daty ma zostać użyty podczas eksportowania do SQL. Jeśli pozostawisz to pole puste, zostanie użyty domyślny skrócony format daty Windows. Charakterystyczne cechy matrycy używane w Delphi : yy i yyyy = rok ( 2 albo 4 cyfry), m i mm = miesiąc ( lub z 0 na początku), d i dd = dzień ( lub z 0 na początku), aby cechy pozostały niezmienione muszą zostać załączone w cudzysłowie (np. : yyyy"/ mm /" dd).

Pamiętaj nazwę ostatnio eksportowanego pliku : Używa nazwy ostatniego pliku jako domyślnej zamiast nazwy katalogu.

Otwórz eksportowany plik po zakończeniu eksportu : Uruchamia stworzony plik po eksporcie.

Indywidualne nazwy plików stron i okładek : Pozwala sprecyzować jak program ma stworzyć nazwy plików skojarzonych ze sobą podczas eksportu

Przykład : Jeśli eksportujesz plik "Moje filmy.amc" do "Moja lista.html" :

Nazwa pliku export.
+ Numer filmu 		Nazwa katalogu
+ Numer filmu 		Tytuł filmu
Cała lista | moja lista.html | moja lista.html | moja lista.html
Pierwszy film | moja lista_1.html | mój film_1.html | matrix.html
Drugi film | moja lista_2.html | mój film_2.html | starwars - episode one.html
itd...

Dodaj rozszerzenie nazwy pliku : Pozwala na wymuszenie innego rozszerzenia dla plików pojedynczych. Może to być w pełni wykorzystane np. wtedy, gdy twoja główna lista jest w pliku .html, a ty chcesz pliki .php dla wszystkich indywidualnych stron filmów. Jeśli to pole jest puste, to rozszerzenie pliku głównego jest używane dla plików indywidualnych.

Do niskich numerów dodaj z przodu zero : Jeśli włączone, to do małych numerów będą dodane zera. Będą więc one właściwie uporządkowane we wszystkich managerach plików (tylko Explorer Windows XP wydaje się dostrzegać numery w nazwach zbioru podczas porządkowania).

Kopiuj okładki do tego samego folderu, co eksportowany plik : Rozpakowuje lub kopiuje okładki z katalogu do tego samego folderu, w którym znajduje się eksportowany plik.

Kopiuj tylko w przypadku, gdy plik docelowy nie istnieje w katalogu : Jeśli ta opcja jest włączona, obraz filmu nie zostanie skopiowany jeśli taka nazwa pliku już istnieje (porównywana jest tylko nazwa pliku, więc obraz nie zostanie zapisany nawet, gdy jest inny).

Foldery

Możesz tutaj zdefiniować zachowanie się okienek dialogowych wyboru pliku :

  • Ładowanie lub zapisywanie katalogów
  • Wybór okładki
  • Eksportowanie
  • Ładowanie lub zapisywanie szablonu HTML
  • Importowanie
  • Uzyskiwanie informacji z plików
  • Zapisywanie grafiki
  • Ładowanie lub zapisywanie skryptów

Opcja "Te same opcje dla wszystkich okien" pozwala zdefiniować ten sam domyślny folder dla wszystkich okien.


Ikony paska narzędzi

Wszystkie elementy Menu są dostępne jako ikony na pasku narzędzi. Domyślnie na pasku narzędzi są najczęściej używane pozycje Menu, ale możesz dostosować je do własnych potrzeb poprzez kliknięcie prawym przyciskiem myszy na pasku i wybranie " Ustawienia -> Ikony paska narzędzi".

Plik

Nowy: Tworzy nowy katalog.

Otwórz: Ładuje plik katalogu. Są dwie ikony "Otwórz". Druga posiada (niewidoczną w Ustawieniach) małą strzałkę po prawej stronie pozwalającą na wyświetlenie ostatnio użytych plików.

Zapisz: Zapisuje katalog pod bieżącą nazwą.

Zapisz jako: Zapisuje katalog pod nową nazwą.

Drukuj: Wyświetla okno Podglądu Wydruku, gdzie możesz wybrać szablon, wygenerować raport i wydrukować go.

Importuj: Pozwala importować dane o filmach z plików w różnych formatach.

Eksportuj: Pozwala wyeksportować katalog do plików w różnych formatach .

Właściwości: wyświetla informacje o bieżącym pliku i katalogu.

Zamknij: Kończy działanie programu.

Film

Dodaj: Dodaje nowy film do listy.

Zmień numer: Pozwala modyfikować numer wybranego filmu.

Usuń: Usuwa bieżący film.

Szukaj: Pokazuje okno "Wyszukiwania", gdzie można odszukać film na podstawie wybranych parametrów.

Pokaż/ukryj okładkę: Pokazuje lub ukrywa okno okładki.

Menu okładki: Pokazuje podmenu z następującymi ikonami...

Wybierz: Pozwala wybrać okładkę, która będzie zapisana w katalogu lub do której zostanie utworzony odnośnik.

Zapisz jako: Zapisuje okładkę do pliku (dostępne tylko dla okładek zapisanych w katalogu, nie działa dla odnośników).

Kopiuj: Kopiuje okładkę do schowka jako bitmapę.

Usuń: Usuwa bieżącą okładkę do filmu (dla zlinkowanych okładek usuwa tylko odnośnik, ale nie usuwa pliku z dysku).

Dokuj/Oddokuj: Zmiana położenia okna okładek. "Dokuj" - zintegrowane z głównym oknem, albo "Oddokuj" - pływające okno.

Kopiuj: kopiuje wszystkie informacje o bieżącym filmie do schowka

Wklej: wkleja informacje o filmie ze schowka.

Cofnij zmiany: Ładuje ponownie dane o bieżącym filmie z katalogu. Są one zapisywane podczas zapisywania katalogu oraz podczas przechodzenia do innego filmu.

Pobierz informacje: Wyświetla podmenu z poleceniami dotyczącymi importu...

z pliku: pozwala na pobranie informacji o filmie z pliku lub z płyty. Możesz uzyskać ten sam efekt stosując metodę "Przeciągnij&Upuść" w głównym oknie programu.

z Internetu: wyświetla okno skryptów, w którym można wybrać odpowiedni skrypt do pobrania informacji o filmie z Internetu.

Szukaj w Internecie: Pokazuje definiowane przez użytkownika menu pozwalające na uruchomienie przeglądarki, do odszukania informacji o filmie na wybranej stronie WWW.

Narzędzia

Grupuj: Grupuje filmy na liście według wybranego pola.

Pokaż w tabeli: Wyświetla wszystkie informacje o wszystkich filmach w formie dużej tabeli.

Skrypty: Wyświetla okno skryptów, które pozwala uruchomić skrypt dla wybranych filmów. Są tu zarówno skrypty internetowe, jak i bezpośrednio związane z katalogiem filmów.

Sortuj filmy: Sortuje filmy w/g wybranych pól i przydziela nowe numery filmom. Przydatne do usuwania pustych numerów powstałych po skasowaniu filmu. Oczywiście, jeśli nie zależy nam na zachowaniu przydzielonych numerów.

Pożyczone: Umożliwia obsługę wypożyczanych filmów. Wyświetla listę wszystkich filmów, które zostały wypożyczone i kto je obecnie posiada.

Statystyka: Wyświetla wykresy statystyczne dla bieżącego katalogu filmów.

Ustawienia: Pozwala zmienić ustawienia programu.

Język: Wybór wersji językowej programu.

Pomoc

Indeks pomocy: Wyświetla niniejszą pomoc.

O programie: Wyświetla informacje o autorze i wersji programu.


Informacje techniczne

Tu znajdziesz nieco technicznych danych o Ant Movie Catalog:

  • Pliki językowe
  • Formaty plików katalogu
  • Tworzenie skryptów
  • Tworzenie wzorców do wydruku raportów


Pliki językowe

Pliki językowe używają składni podobnej do plików INI. Są one plikami tekstowymi, więc możesz je edytować jakimkolwiek edytorem tekstu jak np. Notatnik Windows.

Plik zawiera sekcje. Sekcja jest nazwą w nawiasach. Nazwami sekcji są nazwy okien aplikacji.

np.: [MainWindow]

Pod tym znajdziesz wszystko to, co odnosi się do konkretnego okna. Dane te są parami atrybutów i wartości.

np. : Attribute=Value (Atrybut=Wartość)

Atrybuty są ścieżkami do komponentu do przetłumaczenia, zaś wartość jest nowym tekstem do wyświetlenia. Ścieżka jest złożona z nazwy okna, kropki i właściwość do modyfikacji ("komponent.właściwość"). Niektóre elementy zawierają komponenty wewnątrz komponentów. Czasami pojawiają się tablice, dlatego jest indeks w nawiasach kwadratowych. Właściwości okien zawierają tylko odpowiednią nazwę

np. dla sekcji [ExportWin] :

Caption=Eksport do pliku w innym formacie   //   tytuł okna Eksportu
btn1.Caption=Pomoc   //   nazwa pierwszego przycisku okna Eksportu
Messages.Strings.String[0]=Błąd zapisu   //   pierwsza wiadomość listy
    wiadomości okna Eksportu

Nazwy komponentów używają nazw "standardowych".

Przyciski rozpoczynają się od "btn", Działania (menu/elementy paska narzędziowego) rozpoczynają się od "Action", Znaczniki rozpoczynają się od "CB", Radio przyciski rozpoczynają się od "RB", etykiety rozpoczynają się od L lub LH, Pola danych rozpoczynają się od E, itd...

Podstawowe okno dialogowe może mieć od 0 do 4 przycisków nazwanych btn1, btn2, btn3, btn4; gdzie btn1 jest przyciskiem w prawym, dolnym rogu.

Linia komentarza zaczyna się średnikiem (;) i jest ignorowana przez program.

Istnieje sekcja specjalna, która jest używana do wyświetlania informacji w oknie wyboru języka :

[FileInformation]
Icon= Bitmapa 16x16 (4-bitowy kolor), zakodowana w MIME
Name= Nazwa języka po angielsku
LocalName= Nazwa języka w języku, którego dotyczy
Version= Wersja programu dla której powstał plik (jeśli jest niższa niż VersionFormat, oznacza że część jest ciągle po angielsku)
VersionFormat= Której wersji programu odpowiada struktura pliku
Comments= Dowolny tekst (koniec linii = "|"; odnośnik <link>adres</link>)
Authors=Dane i adres email tłumaczy (każda część oddzielona jest "|":
dane1|email1|dane2|email2


Opis formatu .amc

Opis ".amc" - formatu własnego katalogu

Dane ogólne

Wszystkie zmienne są zmiennymi Pascala, jako że program powstał w Delphi.

Każde pole "tekstowe" jest poprzedzone zmienną integer (4 bajty, ze znakiem), która określa rozmiar wektora (wartość = 0 jeśli brak wektora np. pusty tekst). Zatem teksty w katalogu są zmiennymi string (znak = 1 bajt, bez znaku) bez znacznika końca.

Pole "Picture" jest tablicą bajtów, zawierającą plik obrazka w oryginalnym formacie (PNG/JPEG/GIF).
Format określony jest w polu "PictureName" poprzedzającym "Picture".
Jeśli rozmiar obrazka > 0, to PictureName zawiera oryginalne rozszerzenie pliku ('.png', .'.jpg' lub '.gif').
Jeśli rozmiar pliku = 0 to PictureName zawiera odnośnik do okładki (względny lub bezpośredni), lub nic gdy nie został przypisana do filmu żaden obrazek.

Wersja 3.5

Nagłówek:

strFileHeader35 = ' AMC_3.5 Ant Movie Catalog 3.5.x   www.buypin.com    www.antp.be ';
OwnerName:          string;
OwnerSite:          string;
OwnerMail:          string;
OwnerDescription:   string;

Struktura filmu, powtarzana dla każdej pozycji w katalogu:

Number:           Integer;
Date:             Integer;
Rating:           Integer;
Year:             Integer;
Length:           Integer;
VideoBitrate:     Integer;
AudioBitrate:     Integer;
Disks:            Integer;
Export:           Boolean;
Media:            string;
MediaType:        string;
Source:           string;
Borrower          string;
OriginalTitle     string;
TranslatedTitle   string;
Director          string;
Producer          string;
Country           string;
Category          string;
Actors            string;
URL               string;
Description       string;
Comments          string;
VideoFormat       string;
AudioFormat       string;
Resolution        string;
Framerate         string;
Languages         string;
Subtitles         string;
Size              string;
PictureName:      string;
PictureSize:      Integer;
Picture           array of Byte;

Jedyną zmianą od wersji 3.3 jest usunięcie z nagłówka pola ICQ i zmiana Rating ze zmiennej integer 0-10 na 0-100 (ostatnia cyfra używana jest jako dziesiętna). Wersja 3.4 używa tego samego formatu co wersja 3.3.


Tworzenie skryptów

  • Stałe
  • Funkcje i Procedury
  • Klasy
  • Parametry skryptu
  • Narzędzia debugowania

Plik skryptów są zwykłymi plikami tekstowymi, więc możesz jest modyfikować w dowolnym edytorze. Ale używając wbudowanego w Ant Movie Catalog można łatwo ustalić nagłówek skryptu poprzez okno parametrów skryptu.

Język skryptu podobny jest do Pascala lub Delphi. Jeśli nigdy nie używałeś Pascala, ale znasz się nieco na programowaniu (C, C++, PHP, Java lub inny) powinieneś łatwo opanować zasady, studiując działanie istniejących skryptów.

Użyty tu skrypt to 2 wersja Carlo Kok's Innerfuse Pascal Script.

Większość podstawowych funkcji jest wykorzystywana. Dodano kilka funkcji wymiany danych i stałych. Postaram się je tu przybliżyć.

Skrypt rozpoczyna się blokiem komentarza, który nie jest widoczny podczas edycji w edytorze Ant Movie Catalog. Blok ten zawiera parametry, które mogą być zmieniane przez okno parametrów skryptu.

Oczywiście zostaną znalezione tylko te pliki skryptów, które są w folderze "Scripts".

Stałe:

Te stałe są identyfikatorami pól, użyteczne gdy chcesz ustawić lub odczytać wartość pola filmu.

fieldNumber
fieldChecked
fieldMedia
fieldMediaType
fieldSource
fieldDate
fieldBorrower
fieldRating
fieldOriginalTitle
fieldTranslatedTitle
fieldDirector
fieldProducer
fieldCountry
fieldCategory
fieldYear
         fieldLength
fieldActors
fieldURL
fieldDescription
fieldComments
fieldVideoFormat
fieldVideoBitrate
fieldAudioFormat
fieldAudioBitrate
fieldResolution
fieldFrameRate
fieldLanguages
fieldSubtitles
fieldSize
fieldDisks

Pozostałe stałe:

dirApp: string; zawiera ścieżkę do programu
dirScripts: string; zawiera ścieżkę do katalogu skryptów

Podstawowe Funkcje i Procedury

funkcja Input(tytuł, pytanie: string; var wartość: string): Boolean;
Wyświetla okno pozwalające wprowadzić użytkownikowi tekst. Zwraca True jeśli kliknięto OK, False jeśli kliknięto Anuluj.

funkcja GetPage(adres: string): string;
Pobiera stronę HTML z internetu używając metody GET, i zwraca ją jako string.

funkcja GetPage2(adres: string; przekierowanie: string): string;
To samo co GetPage, ale pozwala na wskazanie adresu "przekierowania" (strony, która wywołuje inną stronę).

funkcja PostPage(adres: string; parametry: string): string;
Eksperymentalnie - Pobiera stronę HTML z internetu używając metody POST, i zwraca ją jako string. Parametry powinny być zakodowane przy użyciu funkcji URLEncode

funkcja PostPage2(adres: string; parametry: string; zawartość: string; przekierowanie: string; wymusHTTP11: Boolean; wymusEncodeParams: Boolean): string;
To samo co PostPage, ale pozwala ustalić również content-type (zamiast 'application/x-www-form-urlencoded' należy podać adres "przekierowania"), wymusić użycie HTTP 1.1 (zamiast 1.0) i wymusić odkodowanie parametrów przez funkcje samoistnie.

procedura GetPicture(adres: string);
Pobiera obrazek i dołącza do bieżącego filmu..

procedura HTMLDecode(var Wartość: string);
Dekoduje znaki HTML zawarte w zmiennej "Wartość" (np. "&eacute;" -> "é").

procedura HTMLRemoveTags(var Wartość: string);
Usuwa tagi HTML ze zmiennej "Wartość".

funkcja URLEncode(źródło: string): string;
funkcja URLDecode(źródło: string): string;
Zmienia znaki na parametry URL (np. " " -> "+") i odwrotnie.

funkcja GetField(pole: Integer): string;
Odczytuje i zwraca wartość wskazanego pola bieżącego filmu.

procedura SetField(pole: Integer; wartość: string);
Zapisuje wartość w podanym polu bieżącego filmu.

funkcja CanSetField(pole: Integer): Boolean;
Informuje skrypt, czy podane pole może zostać zmienione (zostało zaznaczone na liście pól do modyfikacji). Skrypt obecnie nie musi tego co prawda sprawdzać, gdyż SetField nie zmieni pola, jeśli nie zostało zaznaczone. Przydaje się za to przy ściąganiu danych ze stron, gdyż można w ten sposób ograniczyć niepotrzebny transfer.

funkcja CanSetPicture: Boolean;
Podobne do CanSetField, ale wskazuje czy skrypt ma pobierać obrazek.

funcja GetOption(NazwaOpcji: string): Integer;
Zwraca wartość, którą wybrano dla danej opcji. Nazwy opcji i ich wartości są zdefiniowane w oknie parametrów skryptu.

funkcja StringReplace(S, Stare, Nowe: string): string;
Zamienia Stare na Nowe w zmiennej S i zwraca wynik (S nie jest modyfikowane). Używane z #13#10 (bez cudzysłowów), gdy chcemy zamienić znak końca linii.

procedura Error;
Zatrzymuje skrypt na bieżącej linii.

procedura Sleep(Czas: Integer);
Zatrzymuje działanie skryptu na wskazaną ilość milisekund (użyteczne do uniknięcia "connection errors" przy dużych importach).

funkcja CheckVersion(Wersja, Wariant, Numer: Integer): Boolean;
Zwraca True jeśli bieżąca wersja programu jest przynajmniej równa podanym parametrom. (np.3,5,0)

procedura Launch(polecenie: string; parametry: string);
Uruchamia zewnętrzny plik. To może być program, plik lub adres WWW. "Parametry" mogą być pustą zmienną : ''.

funkcja AnsiUpperCase(Wartość: string): string;
Zmienia wszystkie litery w zmiennej na duże. *

funkcja AnsiLowerCase(Wartość: string): string;
Zmienia wszystkie litery w zmiennej na małe. *

funkcja AnsiUpFirstLetter(Wartość: string): string;
Zmienia pierwszą literą w zmiennej na dużą. Pozostałe zostają niezmienione *

funkcja AnsiMixedCase(Wartość: string; Znacznik: string): string;
Zmienia wszystkie litery następujące po literze "Znacznika" na dużą (pierwsza litera też jest zmieniana) Pozostałe zostają niezmienione. *
Znacznik jest łańcuchem zawierającym znaki, po których musi wystąpić duża litera, np.: ' -' da wyniku "To Jest Przykładowy-Tekst".

* Akcentowane litery są również zmieniane, zgodnie z ustawieniami regionalnymi Windows.

funkcja UTF8Encode(Wartość: string): string;
funkcja UTF8Decode(Wartość: string): string;
Zamienia Wartość ze standardu UTF8 (unicode) i odwrotnie. Unicode nie jest dokładnie odzwierciedlany (używając raczej "string" niż "WideString"), więc funkcja zachowuje jedynie znaki z bieżącego zestawu znaków.

funkcja AcceptLicense(Licencja: Integer): Boolean;
Wyświetla okno z zawartością pola "Licencji", zdefiniowaną w oknie parametrów skryptu, z przyciskami "Zgoda" i "Anuluj". Jeśli użytkownik zaakceptuje licencję, nie musi akceptować jej dopóki nie zmieni się numer nadanych w parametrach. Pozwala to pokazać okno licencji wszystkim użytkownikom, ale nie obciążać ich zatwierdzaniem przy kolejnym uruchomieniu skryptu.

procedura SetStatic(ANazwa: string; AWartość: string);
funkcja GetStatic(ANazwa: string): string;
Pozwala odczytać/zapisać "stałe" zmienne: wartości przypisane tej wirtualnej zmiennej, będą zachowane podczas każdego następnego uruchomienia programu. W przeciwieństwie do zwykłych zmiennych, które są tracone po zakończeniu działania skryptu na bieżących filmach.

procedura ShowMessage(Wiadomość: string);
"Neutralne" okno wyświetlające po prostu wiadomość.

procedura ShowError(Komunikat: string);
Okno błędu z komunikatem i ikoną "x" w czerwonym kółku.

procedura ShowInformation(Komunikat: string);
Okno informacji (ikona "i" w baloniku).

funkcja ShowWarning(Komunikat: string): Boolean;
Okno ostrzeżenia (ikona "!" w żółtym trójkącie), z przyciskami "OK" (zwraca True) i "Anuluj" (zwraca False).

funkcja ShowConfirmation(Komunikat: string): Boolean;
Okno potwierdzenia (ikona "?" w baloniku), z przyciskami "OK" (zwraca True) i "Anuluj" (zwraca False).

Funkcje PickTree:

PickTree jest oknem wyświetlającym drzewko używane do pokazania listy dostępnych filmów.

procedura PickTreeClear;
Procedura czyszcząca zawartość okna - uruchom tą procedurę przed użyciem okna, ponieważ nigdy nie jest ono czyszczone automatycznie.

procedura PickTreeAdd(Nazwa, Adres: string);
Procedura dodająca obiekt do okna. Jeśli zmienna Adres jest pusta, obiekt zostanie dodany jako obiekt na poziomie głównym (root). W przeciwnym wypadku zostanie on dodany jako obiekt pochodny. Adres jest zmienną zwracaną przez okno, kiedy użytkownik wybierze ten obiekt.

procedura PickTreeMoreLink(Adres: string);
Procedura ustawiająca adres wskazany przyciskiem "Znajdź więcej" w oknie PickTree. Wartość ta jest czyszczona przez PickTreeClear i przycisk jest nieaktywny, jeśli opcja nie jest wprowadzona przez PickTreeMoreLink.

funkcja PickTreeExec(var Adres: string): Boolean;
Funkcja pokazująca okno. Parametr Adres będzie zawierał adres odnoszący się do wybranego obiektu. Funkcja ta zwraca True, jeśli użytkownik wybrał przycisk OK i False, jeśli wybrał przycisk Anuluj.

Funkcje PickList:

PickList jest oknem wyświetlającym prostą listę, używanym do wyświetlania listy wartości dostępnych dla jednego pola (tak jak opisy lub komentarze). Bieżąco wybrany obiekt jest wyświetlany w dużym oknie tekstowym.

procedura PickListClear;
Procedura czyszcząca zawartość okna - uruchom tą procedurę przed użyciem okna, ponieważ nigdy nie jest ono czyszczone automatycznie.

procedura PickListAdd(Tekst: string);
Dodaje obiekt do okna.

funkcja PickListExec(Powitanie: string; var Wybrano: string): Boolean;
Pokazuje okno, w którym Powitanie jest wyświetlone w podglądzie, gdy żaden obiekt nie jest wybrany. Parametr Wybrano powinien zawierać wybrany obiekt. Funkcja zwraca True, jeśli wybrano OK, lub False, jeśli - Anuluj.

TStringList:

(Nie jestem programistą. Mam nadzieję, że zrozumiecie tłumaczenie (tł.))

TStringList jest klasą używaną do obsługi listy łańcuchów tekstowych. Jest wykorzystane do obsługi stron internetowych, ponieważ pozwala łatwo operować pojedynczymi liniami.

Deklaracja: aList: TStringList;
Utworzenie: aList := TStringList.Create;
Destrukcja : aList.Free;

Jest kilka dostępnych metod:
procedura LoadFromFile(NazwaPliku:string) Ładuje plik tekstowy do listy
procedura SaveToFile(NazwaPliku:string) Zapisuje zawartość listy do pliku
funkcja GetString(NumerLinii:string):string Odczytuje linię
procedura SetString(NumerLinii:string) Ustawia linię
funkcja Count: string Zwraca ilość linii w liście
właściwość Text: string; Właściwość pozwalająca odczytać lub ustawić całą listę jako prosty łańcuch tekstowy (używany np. z funkcją GetPage)

TJvSimpleXml i klasy pochodne

Jest to prawie kompletny parser XML, pozwalający łatwo obsługiwać dokumenty XML. Nie wszystkie funkcje są dostępne przez skrypt, więc poniższa lista zostanie rozszerzona później po dodaniu ich do silnika skryptów.

Tworzenie obiektów jest podobne do TStringList przedstawionej powyżej.

Ma ona następujące metody i właściwości:
procedura LoadFromString(Zmienna: string); ładuje dokument XML ze Zmiennej
procedura LoadFromFile(NazwaPliku: string); ładuje dokument XML z pliku
funkcja SaveToString: string; zachowuje bieżący dokument XML w zmiennej tekstowej
procedura SaveToFile(NazwaPliku: string); zachowuje bieżący dokument XML w pliku
właściwość Root: TJvSimpleXmlElemClassic; koresponduje z elementem "root" dokumentu XML

Różne elementy dokumentu to TJvSimpleXmlElemClassic, oparte na TJvSimpleXmlElem. Ten ostatni ma następujące metody i cechy:
właściwość Name: string; element name: <nazwa>
właściwość Value: string; element value: <nazwa>wartość</nazwa>
właściwość Items: TJvSimpleXmlElems; lista składników elementu
właściwość Properties: TJvSimpleXmlProps; lista właściwości (atrybutów) elementu: <name attr1="val1" attr2="val2">
właściwość Parent: TJvSimpleXmlElem element nadrzędny
funkcja GetChildIndex(AChild: TJvSimpleXmlElem): Integer; pozycja w liście (Items) podanego elementu pochodnego
procedura Clear; usuwa wszystkie składniki i właściwości elementu

Klasa TJvSimpleXmlElems ma następujące metody i właściwości:
właściwość Count: Integer zwraca ilość składników w liście
funkcja GetItem(Index: Integer): TJvSimpleXmlElem; daje dostęp do składnika listy przez podanie jego pozycji
funkcja GetItemNamed(Nazwa: string): TJvSimpleXmlElem; daje dostęp do składnika listy przez podanie jego nazwy
procedura Clear; usuwa wszystkie składniki listy
procedura Delete(Index: Integer); usuwa składnik na podanej pozycji
procedura DeleteNamed(Nazwa: string);usuwa składnik o podanej nazwie
funkcja Add(Nazwa: string): TJvSimpleXmlElemClassic; tworzy i dodaje składnik do listy

Atrybuty każdego składnika to TJvSimpleXmlProp, który ma następujące właściwości:
właściwość Name: string; nazwa atrybutu
właściwość Value: string; wartość atrybutu

Są one przechowywane i obsługiwane przez klasę TJvSimpleXmlProps, która ma następujące metody i właściwości:
właściwość Count: Integer; zwraca ilość właściwości w liście
funkcja GetItem(Index: Integer): TJvSimpleXmlProp; daje dostęp do właściwości listy przez podanie jej pozycji
funkcja GetItemNamed(Nazwa: string): TJvSimpleXmlProp; daje dostęp do właściwości listy przez podanie jej nazwy
procedura Clear; usuwa wszystkie właściwości listy
procedura Delete(Index: Integer); usuwa właściwość na podanej pozycji
procedura DeleteNamed(Name: string); usuwa właściwość o podanej nazwie
funkcja Add(Nazwa: string; Wartość: string): TJvSimpleXmlProp; tworzy i dodaje właściwość do listy

Parametry skryptu

Tytuł, opis i wszystkie pozostałe atrybuty/parametry skryptu mogą być zdefiniowane przy użyciu tego okna. Jest ono dostępne przez ikonę [image] "Właściwości" w edytorze skryptu.

Tytuł skryptu powinien być dość krótki; zazwyczaj jest to nazwa strony z której pobierane są dane. Pole "Pobieranie z internetu" wskazuje czy skrypt może być użyty do pobierania danych z Internetu. Tylko skrypty ze znacznikiem "True" są widoczne w oknie skryptów dostępnych przez "Pobierz informacje" -> "z Internetu używając skryptu". Kiedy okno jest wywoływane przez menu "Skrypty", wszystkie skrypty są widoczne.

Dla każdej opcji, którą zdefiniujesz, możesz określić dostępne wartości (dodatnie liczby całkowite, związane z opisem).

Narzędzia debugowania

Pasek narzędziowy w edytorze skryptów mają komendy podobne do tych dostępnych w Delphi:

  • Przełącznik punktu przerwania: umieszcza punkt przerwania w bieżącej linii, zatem skrypt zatrzyma się po wykonaniu tej linii. Linia będzie podświetlona na czerwono. Możesz umieścić punkt przerwania klikając na lewym marginesie edytora. Tylko punkty przerwania umieszczone na poprawnej linii są używane. Niestety nie jest możliwe oznaczyć wizualnie, które punkty przerwania są niewłaściwe, co robi Delphi podczas wykonywania programu. Gdy wykonywanie skryptu jest zatrzymane, możesz przenieść się do następnej linii przez przycisk "Krok dalej" lub kontynuując wykonywanie przyciskiem "Uruchom".
  • Czyść punkty przerwania: jednym kliknięciem wszystkie punkty przerwania określone w skrypcie.
  • Krok dalej: wykonuje bieżącą linię skryptu (podświetloną na niebiesko) i przechodzi do następnej instrukcji.
  • Uruchom do kursora: wykonuje skrypt do osiągnięcia bieżącej linii (tworzy zatem "wirtualny" punkt przerwania).
  • Analizuj zmienne: wyświeta zawartość zmiennej wskazanej przez kursor.
  • Dodaj śledzenie zmiennej: dodaje do listy śledzenia zmienną wskazaną przez pozycję kursora. Pozwala to określić wartość zmiennej w każdym momencie.


Tworzenie raportów

Tworzenie raportów (wzorców do drukowania)

UWAGA: PROJEKTANT RAPORTÓW JEST PO ANGIELSKU, POZOSTAWIAM ORYGINALNE NAZWY ABY UŁATWIĆ PRACĘ (tł.)

Żeby uruchomić "Projektanta raportów" kliknij na przycisku "Projektant..." w oknie drukowania. Możesz także użyć skrótu, który został dodany do menu Start lub uruchomić AMCReport.exe, który znajduje się w tym samym folderze co Ant Movie Catalog.

"Projektant raportów" jest właściwie edytorem FreeReport i nie uległ praktycznie żadnej modyfikacji (jest raczej złożony, więc prawdopodobnie zostawię go w tej postaci w jakiej jest).

Ta strona pokaże różne sposoby tworzenia raportu.

Wybór rozmiaru papieru.

File -> Page Options - wybór rozmiaru papieru. Zazwyczaj będzie to A4 (lub Letter). Jeśli chcesz, to możesz także wybrać orientację poziomą (Landscape) zamiast pionowej (Portrait).

Ramki

Żeby pola zostały rozpoznane muszą być umieszczone w "Ramkach". Aby umieścić ramkę na stronie, kliknij na ikonie Insert band Insert band (Wstaw ramkę), a następnie na stronie, gdzie chcesz umieścić tą ramkę. Następnie możesz wybrać jaki typ ramki chcesz umieścić:

Insert band type (Typ strefy)

Większość typów nie ma zastosowania. Te, które możesz użyć są następujące:

  • Report title & Report summary : Pojawiają się jedynie na pierwszej stronie (Tytuł i Podsumowanie raportu)
  • Page header & Page footer : Nagłówek i stopka każdej strony
  • Master data : Jest to najważniejsza ramka. Jako jedyna będzie powtarzana dla każdego filmu

Wybierz "Master data" i kliknij "OK". Kolejne okno poprosi o wybranie źródła, zostaw domyślne ("None") i kliknij "OK".

Obiekty tekstowe

Aby umieścić obiekt tekstowy na ramce "Master data", wybierz ikonę Insert rectangle object Insert rectangle object i umieść na ramce (uwaga: jeśli umieścisz poza nią, nie pojawi się ono w końcowym raporcie).

Wyświetli się edytor tekstu:

Możesz tu wpisać jakikolwiek tekst i kliknąć "OK". Aby wywołać to okno ponownie, po prostu dwukrotnie kliknij na obiekcie.

W menu kontekstowym (prawy klik) tego pola tekstowego są trzy opcje:

  • Stretched : Powiększa wysokość pola, jeśli to będzie konieczne
  • Word wrap : Zawija wiersze jeśli są dłuższe, niż pole.
  • Autosize : Powiększa szerokość pola, jeśli to konieczne.

Zmienne (pola filmów i inne)

Żeby umieścić pole filmu, dodaj obiekt tekstowy, we właściwościach ustaw nazwę pola pomiędzy [ ]. Lista nazw pól jest dostępna za pomocą przycisku "Variable" jako "Movie fields" w oknie Edytora tekstu :

Nazwy pól mogą być również wydrukowane przy użyciu zmiennych. Aby tego dokonać musisz dopisać prefiks "label:" przed nazwą pola, cała nazwa i prefiks powinny być w nawiasie kwadratowym (np. [label:Director]). Dostępne jako "Field labels" w "Variable". Jest to użyteczne przy tworzeniu wielojęzycznych raportów (wstawione zostaną nazwy w języku, jaki jest ustawiony w programie)

Jeśli zmienisz kategorię na "Others" będziesz mógł wybrać pola specjalne takie jak: numer strony, data, itp...

Możesz wprowadzić normalny tekst i zmienne w tym samym obiekcie tekstowym.

Grafika

Aby umieścić obrazek, użyj ikony Insert picture [image]. Okno obrazka wygląda tak:

Aby wyświetlało ono okładkę bieżącego filmu, kliknij na przycisk "Memo" i wpisz "[Picture]" lub wybierz z listy zmiennych ("Variable").

W menu kontekstowym okna obrazka, są trzy opcje:

  • Stretched : dopasowuje obrazek, aby pasował do rozmiaru obiektu
  • Center picture : ustawia obrazek pośrodku obiektu
  • Keep aspect ratio : zachowuje proporcje obrazka podczas dopasowania

Możesz także rysować linie używając ikony Draw line lines.

Skrypty

W oknie edytora tekstu oraz okna obrazka (po wejściu w Memo) jest u góry opcja "Script". Po jej zaznaczeniu otworzy się u dołu okno w którym można wprowadzić komendy skryptu. Skrypt ten nie jest związany z tymi używanymi przez Ant Movie Catalog, poza użyciem tego samego języka programowania - Pascala. Oto kilka przykładów:

  • Jeśli chcesz aby obrazek pojawiał się tylko dla filmów komediowych, umieść następujący kod w skrypcie w części Memo obrazka:

    begin
  Visible := [Category] = 'Komedia';
end;
    Uwaga: kategoria jest uwzględniana tylko w całości i dokładnie; w powyższym przykładzie nie zostanie uwzględniona np. "Komedia / Wojenny" ani "komedia".

  • Jeśli chcesz umieścić rok w nawiasach po tytule filmu tylko, gdy został on podany (aby uniknąć wstawienia pustych nawiasów) wykorzystaj poniższy skrypt w oknie edytora tekstu:

    begin
if ([Year] <> '') then
  tmp1 := [OriginalTitle] + ' (' + [Year] + ')'
else
  tmp1 := [OriginalTitle]
end;

    Zaś w oknie edytora umieść [tmp1], aby wyświetlić wynik skryptu jako nową zmienną.

Wiele funkcji Projektanta Raportów nie jest wykorzystanych, jak np. pola DB, podgląd wydruku, podraporty...
Obecnie jedyną metodą podglądu wydruku jest zapisanie wzorca i użycie "Odśwież" w oknie Ant Movie Catalog, oczywiście po wskazaniu zapisanego wzorca z listy.

W przypadku problemów z polami filmu, upewnij się, że są one umieszczone na ramce "Master data". Jeśli niektóre pola nie działają (np. "Total pages"), sprawdź czy zaznaczone jest "Two pass report" w File -> Report Options.


Historia programu

Lista zmian

  • 3.5.0 (?)
    • Link do MediaInfo.dll do importowania danych z plików innych niż AVI: OGM, MKV, RM, WMV, DVD (IFO/VOB).
    • Opracowane od nowa okno skryptów. Obecnie skrypty mogą definiować zmienne, które mogą być łatwo zmienione przez użytkowników. Mogą oni także ustalić, które pola mogą być modyfikowane. Zostało również dodanych kilka nowych funkcji dla skryptów oraz parsera XML. Zmieniono też okno "Wyników skryptu".
    • Funkcje debuggingu dla skryptów: krok po kroku, punkty kontrolne, obserwacja zmiennych itp.
    • Moduł skryptowy może obecnie wykorzystywać zewnętrzne pliki: jeśli umieszczona zostanie w skrypcie nazwa modułu w "uses", skrypt będzie usiłował znaleźć plik o podanej nazwie z rozszerzeniem .pas lub .ifs w bieżącym katalogu.
    • "Importuj okładkę" i "Zlinkuj okładkę" zostały połączone i wybór następuje przez zaznaczenie opcji w oknie "Wybór okładki". Dołożono opcję w oknie "Ustawień" pozwalającą określić, czy wolisz dołączać pliki do bazy, czy tworzyć linki do plików. Pozwala to pominąć obsługę tego fragmentu importu w skryptach.
    • Okna Eksportu, Drukowania, Statystyki i Skryptów mają obecnie opcje do obsługi wszystkich filmów, bądź tylko wybranych, zaznaczonych lub widocznych.
    • Przy pierwszym uruchomieniu pojawia się okno wyboru wersji językowej. Mam nadzieję, że pozwoli to uniknąć listów od użytkowników w pytaniami, jak przełączyć program np. na wersję polską. ;)
    • Wirtualne pole "Tytuł sformatowany" wykorzystywane przy sortowaniu; teraz możliwe jest właściwe posortowanie przetłumaczonych tytułów. Dołączone zostało pole "zaznaczony" (znaczniki w głównym oknie listy filmów).
    • Pole "Ocena" ma obecnie jedno miejsce dziesiętne jak w IMDB.
    • Nazwy pól mogą być użyte w drukowanych raportach, zatem zostały również przetłumaczone (użycie: [etykieta:nazwa pola], gdzie "nazwa pola" jest taka sama, jak ta użyta przy wyświetleniu jednego z pól filmu.
    • Akceptowane są powtarzające się numery filmów (i dla tych, którzy nadal chcą używać pojedyńczej numeracji w oknie "Dodaj film" są opcje na wypadek powtórzenia numeru)..
    • Grupowanie: dodano opcje do połączenia filmów, jeśli są jedyne w danej grupie. Jest to przydatne przy grupowaniu według numerów lub etykiet.
    • Zmieniono niektóre skróty w głównym oknie na bardziej logiczne
    • Wiele innych małych poprawek i udogodnień.
  • 3.4.3 (28/02/2004)
    • Poprawiono błąd uniemożliwiający uruchomienie na niektórych procesorach Pentium 4.
    • Zmiana licencji: oprócz freeware, program podlega również prawom OpenSource (GPL).
  • 3.4.2 (02/03/2003)
    • Import/Eksport z/na stronę Origons.
    • Kilka nowych opcji w "Opcjach eksportu" i w oknie Ustawień.
    • Poprawiono kilka bugów.
  • 3.4.1 (22/12/2002)
    • Okno okładek może być umieszczone po prawej stronie okna głównego.
    • Załadowana okładka (w pobierz info ze skryptu) może być podejrzana przed kliknięciem OK.
    • Opcja generowania "uaktualnij" zamiast "umieść" w eksporcie do SQL.
    • Komendy "Znajdź & Znajdź kolejne" w Edytorze Skryptu.
    • Poprawiono kilka bugów i dodano kilka innych opcji.
  • 3.4.0 aktualizacja (04/10/2002)
    • Poprawiono kilka detali.
    • Dodano importowanie bazy danych DivX Managera 1.0.
  • 3.4.0 (08/09/2002)
    • Drukowanie przy użyciu szablonów.
    • W trybie "Siatki" zapisywane są szerokości kolumn i uporządkowanie.
    • Ładowanie warstwowe : powinno rozwiązać parę problemów z Głównym oknem i oknem skryptu podczas ładowania strony internetowej.
    • Import video i audio bitrate z plików AVI.
    • Funkcje modyfikowania liter (duże litery, małe litery, mieszane litery...) w narzędziu skryptowym.
  • 3.3.1 (30/07/2002)
    • Obsługa pliku XML : możesz wybrać XML dla twoich katalogów zamiast formatu binarnego pliku ".amc".
    • Zawartość ustawień i list "przeciągnij i upuść" jest przechowywana w pliku XML zamiast w plikach INI/TXT.
    • Dodano opcje list "przeciągnij i upuść", np. możliwość użycia wartości katalogu zamiast ponownego definiowania list.
    • Importowanie obrazków podczas importu baz danych Divx Manager & BaseDVDivx.
    • Kliknięcie na obrazku w głównym oknie wyświetla nowe okno z obrazkiem o pełnym rozmiarze.
    • Ustawienia domyślne nowego filmu mogą być modyfikowane z poziomu okna Ustawień.
    • Możliwość zlinkowania obrazków, które są przeciągnięte i upuszczone w oknie głównym.
    • Opcja ustawień rodzaju nazwy pliku, który ma być eksportowany.
    • Podczas eksportowania do SQL lub CSV, kolumna zawierająca nazwę pliku jest dodawana podczas eksportu pliku.
    • Zapytanie o stronę internetową ze skryptu może być dokonane za pomocą komendy POST zamiast GET jeśli to konieczne (eksperymentalnie).
    • Ikony flag w oknie wyboru języka.
  • 3.3.0 aktualizacja (22/06/2002)
    • Poprawione sortowanie listy filmów w oknie filmów pożyczonych.
    • Dodano skrypty.
  • 3.3.0 aktualizacja (10/06/2002)
    • Poprawiono bug w eksporcie SQL (widoczne tylko w systemach Unicode).
    • Poprawiono bug w eksporcie SQL (widoczne tylko w systemach Unicode).
  • 3.3.0 (26/05/2002)
    • Dwa nowe pola : "Źródło" (skąd/jak zdobyłeś film) i "Typ nośnika" (CD, DVD, VHS, ...).
    • Komenda "Grupuj wg" cechy (w menu "Narzędzia"), która pozwala wyświetlić listę w formie drzewka.
    • Tryb "Zacieniona siatka", wyświetlający informacje o wszystkich filmach na dużej liście zamiast standardowego widoku (w tej chwili nie możesz niczego modyfikować używając tego trybu).
    • Okno wyszukiwania, które zachowuje się jak pasek narzędzi pozwalając na wyświetlanie go podczas używania listy. Także opcja "Wyświetl wyniki", która wyświetla tylko filmy pasujące do wybranych kryteriów.
    • Pozwala wybrać więcej, niż jeden film podczas usuwania, zaznaczania/odznaczania, skryptowania,...
    • Zapisuje porządek kolumn (zarządzanie głównym oknem i oknem pożyczek).
    • Uaktualnienie TPNGImage : obrazy PNG obsługują 32 bity.
    • Wyłączona animacja GIF, ponieważ bardzo wolno się ładowała.
    • Nowe okno obrazków : Dokuj/Oddokuj działa dużo lepiej
    • Uaktualniono do tb2k/tbskin 2.0.13.
    • Import innego pliku .amc do pliku bieżącego.
    • Import plików .bdv z BaseDVDivx 2.5.
    • Import baz danych DivxManager 0.5, 0.6 & 0.8.
    • Export pełnych lub pojedynczych plików HTML : pozwala na stworzenie jednego pliku do jednego filmu, użyteczne do długich list.
    • Podczas importowania informacji z plików avi/divx, program importuje nazwę kodeka video & audio.
    • Import plików filmowych z www.moviecovers.com.
    • Dużo szybsze start&wyjście i odświeżanie listy.
    • Tryb skryptu : Uruchamia skrypt listy filmów, który pozwala na masowy import, znajdź & zamień, etc...
    • W oknie skryptu wyświetlane są skrypty znalezione w folderze "Skrypty", do łatwego wyboru skryptu.
    • Import obrazka do filmu ze skryptów jako dodatek do informacji o filmie.
    • Kolorowy edytor HTML & Skryptu.
    • Opcja automatycznego uruchomienia ostatnio używanego skryptu podczas otwierania okna skryptu.
    • Opcja otwierania wybranego katalogu przy starcie lub ponownym otwarciu ostatnio używanego katalogu.
    • Opcja wstawiania słów takich jak "The", "A", ... na końcu tytułu podczas wyświetlania na liście (domyślnie na liście znajdują się angielskie i francuskie słowa).
    • Opcja wyłączenia autokompletowania w listach "przenieś i upuść", ponieważ niektórzy ludzie mieli z tym problemy.
    • Podczas dodawania filmu, opcja użycia pierwszego dostępnego numeru zamiast najwyższego numeru + 1. Także opcje automatycznego wywołania "Pobierz info ze skryptu" i "Pobierz info z pliku".
    • Kilka innych opcji.
    • Poprawiona ikona 16x16 dodana ikona 48x48.
  • 3.2.1 aktualizacja (26/02/2002)
    • Poprawiono bug z Oknem postępu (otwórz/zapisz/export/...) i okna trybów.
    • Poprawiono bug importu CSV (w wersji 18/02/2002).
    • Uaktualniono do nowej wersji Toolbar2000 i TBSkin.
  • 3.2.1 (16/02/2002)
    • Poprawiony system skryptu, dodany skrypt do importu danych z www.allocine.fr, oraz poprawiony bug : przerwij jeśli importowane są zbyt długie opisy.
    • Poprawiony bug nieprzetłumaczonych obiektów pod Windows 95/98, teraz wszystkie powinny być tłumaczone poprawnie.
    • Poprawiona prędkość odświeżania listy filmów (podczas ładowania listy filmów, zatwierdzanie opcji numerowania filmów).
  • 3.2.0 (09/02/2002)
    • Możliwość importu informacji o filmie z internetu ! Używany jest system skryptu w języku Object Pascal. Ta wersja zawiera tylko skrypt do importu danych z IMDB ale pozostałe skrypty zostaną wkrótce poprawione.
    • Konfigurowalne menu, które może uruchomić przeglądarkę w celu przeszukania internetu, aby uzyskać informacje o filmie.
    • Historia wypożyczeń, logowana w pliku CSV.
    • Ustawianie różnych ikon paska narzędzi, który może być modyfikowany przez użytkownika przez dodawanie plików .bmp do folderu aplikacji.
    • Na wykresie (w oknie Statystyk) dodano framerate, rok i czas trwania.
    • Przystosowano tag linii przerw dla eksportu HTML.
    • Nowe okno funkcji "Sortowania filmów" pozwalają wybrać, jak uporządkować filmy przed przenumerowywaniem.
    • Nowa wersja Toolbar2000 i TBSkin.
    • Wspieranie tematów Windows XP (używa skór Windows).
    • Poprawiono bug zaawansowanego sortowania i kilka innych bugów.
    • Konwersja pliku pomocy do formatu *chm
  • 3.1.0 aktualizacja (08/01/2002)
    • Poprawiono kilka małych bugów.
  • 3.1.0 (22/12/2001)
    • Nieograniczona długość pola (właściwie ograniczona do 2147483647 znaków pod Windows NT / 2000 / XP i 65535 pod Windows 95/98 / Me).
    • Nowe pola: Format audio, Audio & Video bitrate, Liczba dysków, Framerate, Etykieta/kod kreskowy.
    • Statystyki: wykres ze statystyk danych katalogu, np. częstotliwość dodawania, kraje, kategorie, etc...
    • Nowe okno Szukania, pozwala wyszukiwać na podstawie któregokolwiek pola.
    • Dodawanie nowego filmu poprzez "Przeciągnij i upuść", kiedy żaden film nie jest wybrany.
    • Nowe funkcje okładek: "Kopiuj okładkę do schowka", "Link okładki" (tylko zapisuje link do okładki zamiast gromadzić je w katalogu).
    • Wspierany format PNG.
    • Obraz włączył do filmu operacje kopiuj / wklej.
    • Nowe opcje: "Dopasuj okładkę do okna", "Nie pokazuj logo na starcie", klawisze skrótu, by pójść do poprzedniego / następny film bez rozwiązywania aktywnego pola..
    • Nowy tag eksportu do HTML: $$FORMATTEDTITLE 1 & 2.
    • Nowy pasek narzędzi & system menu i skóry do nich (Office 2000, Office XP, Windows XP).
    • Nowa właściwość katalogu: "Opis".
    • Konwersja z Delphi 5 do Delphi 6.
  • 3.0.1 (28/10/2001)
    • Pełna translacja na francuski, inne języki w przyszłości.
    • Lepsze obsługiwanie plików "Przeciągnij i upuść".
    • Można zapisać kopię okładki filmu do nowego pliku.
  • 3.0.0 aktualizacja (24/10/2001)
    • Naprawiono mały błąd z Windows XP i polem numeru (pole z strzałkami, by zmienić wartość).
    • Naprawiono dziwny błąd, który niepokoił trochę system: kiedy program został uruchomiony to zawsze pytał, czy użytkownik chce zapisać plik.
  • 3.0.0 (14/10/2001)
    • Nazwa programu zmieniła się: teraz to jest Ant Movie Catalog zamiast ANSYsoft Movie Catalog, ponieważ grupa ANSYsoft rozpadła się.
    • Obrazy i wypożyczenia są zgromadzone wewnątrz plik katalogu. Właśnie dlatego pliki są większe. Takie pliki jak: .jpg, .gif i .pliki amcl nie są użyteczne i są zawarte w pliku .amc.
      Dodano możliwość aby zapisać katalog bez okładek (np., by wysłać mailem mniejszy plik) przez wybieranie "Ant Movie Catalog 3.0 bez okładek lub wypożyczeń" w oknie "Zapisz jako".
    • Lepsza data obsługująca pole "Data dodania".
    • Pozwolono, by zgłosić pustą wartość w polu roku albo długość w informacji filmu.
    • Wybrany film pojawia się na liście kiedy szukasz albo dodajesz film.
    • Numer filmu może zostać zmodyfikowany (związany z kontekstem w liście filmu albo z listą "Film").
    • Okno postępu kiedy ładuje / zapisuje.
    • Usunięto okno "Importuj informację z filmu" , gdyż nie było za bardzo przydatne. Teraz można użyć metody "Przeciągnij i upuść" plik wideo w Głównym oknie, aby importować wielkość pliku. Jeśli to jest plik AVI albo Divx , to również długość może też zostać importowana.
    • Zmieniono konstrukcję i dołożono kilka opcji w oknie Opcji.
    • Lepsze zarządzanie szablonem eksportu do HTML.
    • Opcja do wyszczególniania, czy okładki muszą być eksportowane przeniesiona została z okna Opcji do okna Eksport.
    • Funkcja eksportu "Tylko okładki".
    • Modyfikacja okna Właściwości.
    • Wyświetla się logo na starcie.
    • Dużo drobnych poprawek
  • 2.1.1 aktualizacja (14/08/2001)
    • Poprawiony błąd w oknie " Zapisz jako" i w innych podobnych oknach..
  • 2.1.1 (22/07/2001)
    • Częściowe tłumaczenie na język francuski.
    • Poprawa bugu w eksporcie do SQL.
  • 2.1.0 (12/07/2001)
    • Poprawiono dużo małych błędów
    • Numery filmów w katalogu są widoczne na pasku tytułu.
    • Ostatnio używane pliki w menu Plik.
    • Związane z kontekstem menu dla listy filmu głównego okna.
    • Funkcja "Przenumeruj filmy".
    • Okno okładek może zostać zdokowane w Głównym oknie.
    • Wspierane "Przeciągnij i upuść dla głównego okna : pliki mogą zostać otworzone w ten sposób.
    • Opcja "Znaczniki" w oknie "Głównym" listy filmów, aby wyszczególnić, czy chcesz dodać film do eksportu czy nie.
    • Nowe pole : "Data dodania", więc jest nowa struktura pliku ( program może nadal otworzyć stare pliki, ale poprzednie wersje są niezdolne do otwarcia plików zapisanych przez nową wersją).
    • Okno własności pliku, które może zawrzeć informację o autorze / właścicielu katalogu.
    • Ten sam styl paska narzędzi dla wszystkich okien (szary albo kolorowy zależnie od wyboru użytkownika w oknie Ustawień).
    • Szukanie filmu bazuje na tytule w oknie Głównym i w oknie Wypożyczeń.
    • Numery filmów w oknie "Wypożyczeń". Widoczne jest jakie filmy ma każdy pożyczający.
    • Zaawansowane opcje sortowania w oknie Eksportu.
    • Komendy eksportu do SQL
    • Kilka nowych tagów w eksporcie HTML
  • 2.0.0 (30/05/2001)
    • Import i eksport plików CSV ( pliki tekstu, gdzie zakres pole jest ustalony przez specjalny znacznik, używany w większości baz danych i programów).
    • Poprawiono błędy zmodyfikowanego wykrywania pliku.
    • Informacja importu może utworzyć powiązania wszystkich wielkości wybranych plików (np. 600 + 350 + 100 zamiast 1050).
    • Rozwiązano parę problemów paska narzędzi (nie wszystkie).
    • Poprawiony błąd w tytule porządkującym eksportu do funkcji identyfikatora
    • Okno wypożyczeń, które pozwala na zarządzanie wypożyczeniami filmów od ciebie przez znajomych.
  • 1.1.0 (15/04/2001)
    • Nowe pole dla informacji filmu : Okładka i Ocena.
    • Nowa struktura pliku (wymagana dla nowego pola). Pliki od wersji 1.0 są nadal wczytywane (to oczywiste !), ale nowe pliki nie będą użyteczne ze starą wersją programu.
    • Poprawiono okno Eksportu.
    • Importowanie informacji z plików video.
    • Szerokość listy filmu jest teraz oszczędniejsza.
    • Programowalne okno Ustawień.
    • Przystosowalny pasek narzędzi.
    • Kopiuj / Wklej informację filmu (np., by wymienić informację między dwoma przykładami aplikacji biegnącej równocześnie).
    • Poprawiony błąd w "Cofnij zmiany".
    • Strona pomocy.
  • 1.0.0 (18/03/2001)
    • Pierwszy wersja. Wszystkie funkcje nie są jeszcze nie skończone. To będzie poprawione w następnych wersjach.


O programie

O programie, podziękowania & linki

Program ten został napisany przez Antoine Pottena z BuyPin Software, w Borland Delphi 6 pod Windows XP.

Program powinien poprawnie funkcjonować pod Windows 95, 98, Me, NT4 SP4, 2000, XP i został przetestowany przeze mnie na tych platformach (oprócz Windows Me, ale i tu powinien funkcjonować poprawnie).

Jeśli posiadasz Windows 95, 98 albo NT4, to może zajść potrzeba aktualizacji twojego systemu. Na stronie domowej autora programu znajdziesz linki do niezbędnych aktualizacji

Zrobiłem ten program, ponieważ nie mogłem znaleźć odpowiedniego oprogramowania, które by było w stanie zarządzać moją kolekcją filmów i w prosty sposób tworzyć strony HTML z listą tych filmów.

Program ten jest rozpowszechniany na zasadach freeware; możesz go swobodnie rozprowadzać oraz modyfikować zgodnie z zasadami GNU General Public License ogłoszonymi przez Free Software Foundation (wersja 2 lub każda późniejsza).

Program ten jest rozpowszechniany w nadziei, że będzie użyteczny, ale BEZ ŻADNYCH GWARANCJI; nawet wynikających z obowiązków SPRZEDAWCY. Dokładne informacje uzyskasz na stronie GNU General Public License

Kontakt

  • Mail: software@antp.be
  • Strona Ant Movie Catalog: www.antp.be/software/moviecatalog/

Podziękowania

Dziękuję poniższym portalom za udostępnienie dostępu do danych przez użytkowników Ant Movie Catalog:

  • DVDFR
  • Culturalia

Ikony użyte w zestawach pochodzą z:

  • Scrows' glyphs collections
  • Gnome
  • Everaldo's Crystal icons

Użyte składniki:

  • InnoSetup, wykorzystano przy procedurach instalacji
  • MediaInfo, wykorzystano bibliotekę DLL
  • Niektóre składniki z JVCL
  • Innerfuse Pascal Script wersja 2
  • TPNGImage
  • CorelButton
  • Toolbar2000
  • TBX
  • SynEdit
  • ElTree Lite
  • FreeReport
  • MyLittleBase, wykorzystano w DLL obsługującym import z BaseDVDivx

Tłumaczenie:

  • Belarussian: dzmitry[li]
  • Bulgarian: Rumen Stoyanov & Momchil Karabulev
  • Catalan: Pau Bosch i Crespo
  • Croatian: Josip Martinčević
  • Czech: Jan Kaltoun & Petr Kříz
  • Danish: Bent Mřller Madsen
  • Dutch: Marcel Buyle & Harm Caspers
  • Estonian: Junos
  • Finnish: Jukka-Pekka Jussila
  • French: Antoine Potten
  • German: Juergen Venne & Bad Joker
  • Greek: AllDivXGR
  • Hebrew: Erez Ben Ari
  • Hungarian: Herczeg József Tamás
  • Italian: Jancker & Dino Librandi
  • Korean: Ju Eul, Jang & J.S.Lee
  • Latvian: Aldis Bîbers
  • Lithuanian: Vytautas Ribikauskas
  • Norwegian: Kai V Findahl
  • Polish: Adam "Adma's" Malich oraz Bogdan Kwietniak
  • Portuguese (Brazil): Filipe Guimarăes
  • Portuguese (Portugal): Ricardo Ribeiro
  • Romanian: Dragos Medinschi
  • Russian: Alexei Chehowskoi & Vitaliy Krivchikov
  • Serbian: Zoran Nikolic ("Zoni")
  • Slovak: Berry
  • Slovenian: Pete Minus
  • Spanish: Sergio Marrero Ponce
  • Swedish: Andreas Johansson
  • Turkish: Kemal Seçer & Özkan Ak